Mail delivery issues

Incident Report for Cloud86

Resolved

The issues have been resolved.
Posted Apr 14, 2025 - 10:42 CEST

Monitoring

We have found the cause, implemented a fix and have requested the blocks to be removed from the various DNSBL lists.
Posted Apr 10, 2025 - 15:24 CEST

Investigating

We are aware that the IP addresses of a number of Shared servers are currently listed on external DNSBL lists which can cause mail delivery issues, we are investigating and will provide a new update soon.
Posted Apr 10, 2025 - 10:23 CEST