We have applied a mitigation on the server to suppress the attack. The side effect is that some issues can occur with mail and FTP/SFTP. Regarding the mail, we do have a webmail which is not affected by this. use https://webmail.mwp67.cloud86-host.io
Posted Mar 25, 2025 - 08:51 CET
Monitoring
A fix has been implemented for some time now. We are monitoring the situation.
Posted Mar 24, 2025 - 19:42 CET
Identified
The issue has returned, we are in contact with our datacenter partner to apply new mitigations.
Posted Mar 24, 2025 - 16:54 CET
Monitoring
The issue is determined to be caused by a denial of service (DoS) attack, we have implemented mitigations and the server is back online. We will continue to monitor the situation.
Posted Mar 24, 2025 - 16:22 CET
Investigating
The availability issues affecting mwp67 have unfortunately returned, we are investigating and will provide a new update soon.