Incident: Admin Portal Email Delivery Issue (Password-Resets Affected)

Incident Report for Cloud86

Resolved

This incident has been resolved.
Posted May 16, 2025 - 07:14 CEST

Monitoring

The cause has been identified and a mitigation has been implemented.
Posted May 15, 2025 - 15:35 CEST

Investigating

We are currently experiencing a problem that prevents the My Cloud86 portal from sending any outgoing email. As a result, password-reset messages and other system notifications are not being delivered.

Impact
* Password-reset emails are delayed or undelivered.
* All other automated emails generated by the admin portal are also affected.
* Customer mailboxes and customer-facing email traffic remain fully operational and are not impacted.

Our engineering team is actively investigating and working on a fix. Restoring email functionality—especially password resets—is our top priority.

We apologise for the inconvenience and appreciate your patience while we resolve this issue.
Posted May 15, 2025 - 14:17 CEST
This incident affected: My Cloud86.