DDoS attack shared141.cloud86-host.io

Incident Report for Cloud86

Resolved

This incident has been resolved.
Posted Aug 15, 2026 - 08:13 CEST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2026 - 20:46 CEST

Update

Mitigations have been implemented, websites are responding again although slower than normal.
Posted Aug 14, 2026 - 15:33 CEST

Identified

The server is currently under DDoS attack which has caused websites hosted on the server to be slow or unavailable. We are exploring mitigation options.
Posted Aug 14, 2026 - 13:53 CEST
This incident affected: Shared Webhosting.